Mengatasi Ping reply besar + Mikrotik

Setelah beberapa hari limiter jalan, saya masih sering dapat complain tentang salah satu lab disaat full maka “ping” replynya sampai ribuan ms bahkan kadang-kadang putus / tidak reply. asumsi orang (sugesti) bahwa kalau ping besar koneksi lambat…. apalagi kalau ada putus dipikir kita “ngak fair” bagi bandwidthnya….wah ini salah kaprah. coba dijelaskan juga, dasar user adalah raja … dan dari pada nantinya saya dibilang kerja ngga “bejussss” …. ya akhirnya surfing dan tanya – tanya sama om google.

kenapa ping bisa besar ?? karena limit bandwidth di koneksi dia sudah habis/mepet. nah icmp yang akan lewat “diapsen” dan akan di “antri” ….

64 bytes from 66.94.234.13: icmp_seq=1 ttl=48 time=1045.0 ms
64 bytes from 66.94.234.13: icmp_seq=2 ttl=48 time=1922.0 ms
64 bytes from 66.94.234.13: icmp_seq=5 ttl=49 time=2013.0 ms
64 bytes from 66.94.234.13: icmp_seq=6 ttl=48 time=1903.0 ms
64 bytes from 66.94.234.13: icmp_seq=7 ttl=48 time=1979.2 ms
64 bytes from 66.94.234.13: icmp_seq=8 ttl=48 time=1932.0 ms
64 bytes from 66.94.234.13: icmp_seq=9 ttl=48 time=2300.2 ms

Triknya adalah menyediakan sedikit bandwidth dari limitnya lab bersangkutan untuk didedikasikan packet ICMP.

pertama tama bikin manglenya :
/ip firewall mangle add chain=forward src-address=192.168.0.64/
28 protocol=icmp action=mark-connection new-connection-mark=lab1icmp-cm passthrough=yes
/ip firewall mangle add chain=forward connection-mark=lab1icmp-
cm action=mark-packet new-packet-mark=lab1icmp-pm passthrough=yes
/ip firewall mangle add chain=forward packet-mark=lab1icmp-pm a
ction=change-tos new-tos=min-delay

Ok sekarang bikin Queuenya
Skema saya adalah sebagai berikut :
Bandwidth 128 Kbps : 4 Kbps untuk ICMP sisanya untuk service internet lainnya…
pertama kita dedikasikan dulu bandwith yang nanti dijadikan parent oleh rule queue yang kita buat.
/queue tree add name=lab1-down parent=Downstream max-limit=128k
kemudian kita pecah menjadi:
/queue tree add name=downlab1 parent=lab1-down packet-mark=lab1
-pm queue=default max-limit=124k
/queue tree add name=icmplab1 parent=lab1-down packet-mark=lab1
icmp-pm queue=default max-limit=4k
Hasilnya :
64 bytes from 66.94.234.13: icmp_seq=22 ttl=48 time=655.3 ms
64 bytes from 66.94.234.13: icmp_seq=23 ttl=48 time=645.0 ms
64 bytes from 66.94.234.13: icmp_seq=24 ttl=49 time=645.0 ms
64 bytes from 66.94.234.13: icmp_seq=25 ttl=48 time=635.0 ms
64 bytes from 66.94.234.13: icmp_seq=26 ttl=48 time=634.7 ms
64 bytes from 66.94.234.13: icmp_seq=27 ttl=48 time=634.8 ms
64 bytes from 66.94.234.13: icmp_seq=28 ttl=48 time=655.3 ms

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: